Вопрос задан 24.03.2019 в 03:44. Предмет Информатика. Спрашивает Назаров Олег.

Составить программу в с++ Дано натуральное число: 1) найти кол-во четных цифр этого числа 2) верно

ли, что в Данном числе встречается A и B (числа A и B вводится с клавиатуры)
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Тюрин Андрей.
1)
#include <iostream>
#include <stdlib.h>

using namespace std;

int main() {
    int a, k = 0;
    cin >> a;
    for(int b = abs(a);b > 0; b/=10)
        if(b%10%2 == 0) k++;
    cout << k << endl;
}
2)
#include <iostream>
#include <stdlib.h>

using namespace std;

int main() {
    int n, a, b;
    bool flagA = false, flagB = false;
    cin >> n >> a >> b;
    for(int d = abs(n);d > 0; d/=10) {
        if(d%10 == a) flagA = true;
        else if(d%10 == b) flagB = true;
    }
    cout << ((flagA && flagB) ? "true" : "false") << endl;
}


0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос