Вопрос задан 23.03.2019 в 23:45. Предмет Информатика. Спрашивает Смирнов Евгений.

В массиве хранится информация о средней цене продуктов за месяц. Составить программу, которая

подсчитывает сколько продуктов стоили дороже 150 руб. Элементов в массиве-15, диапазон цен- от 0 да 200руб. На экран вывести все элементы массива и элементы удоволетворяющие нашему условию. Напиши полностью программу)
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Лисунов Артём.
Const n=15; 
var a:array[1..n] of integer;
i,k:integer; 
begin
Randomize;
writeln('Массив Цены');
for i:=1 to n do
 begin
 a[i]:=random(201);
 write(a[i]:4);
 end;
writeln;
k:=0;
writeln('Дороже 150 руб:');
for i:=1 to n do
 if a[i]>150 then begin write(a[i]:4); k:=k+1; end;
writeln;
writeln('k = ',k);
end.

Пример:
Цены:
136 16 50 45 62 41 163 149 175 35 14 51 110 156 175
Дороже 150 руб:
163 175 156 175
k = 4
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос