Вопрос задан 21.03.2019 в 16:20.
Предмет Информатика.
Спрашивает Клишина Александра.
Составьте программу, позволяющую определить, являются ли числа A,B,C, пифагоровыми
тройками.Указанные числа A,B,C, являются пифагоровыми тройками, если квадрат одного из чисел равен сумме квадратов двух других.Ответы на вопрос
Отвечает Колесникова Валерия.
Program pifThi;
var
a,b,c:integer;
begin
readln(a,b,c);
if (sqr(a)=sqr(c)+sqr(b)) or
(sqr(b)=sqr(a)+sqr(c)) or
(sqr(c)=sqr(a)+sqr(b)) then write('Yes!')
else write('No!'); readln;
end.
var
a,b,c:integer;
begin
readln(a,b,c);
if (sqr(a)=sqr(c)+sqr(b)) or
(sqr(b)=sqr(a)+sqr(c)) or
(sqr(c)=sqr(a)+sqr(b)) then write('Yes!')
else write('No!'); readln;
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
