Вопрос задан 21.03.2019 в 05:00.
Предмет Информатика.
Спрашивает Левченко Лера.
Напишите программу, которая для каждого из трех чисел, введенных чисел с клавиатуры пользователем,
определяет является это число четным или нечетным, двузначное оно или нет и кратно ли оно 3.Ответы на вопрос
Отвечает Шарикова Елена.
//прога на Pascal`e
var
a: array of int64;
n: longint;
i : byte;
begin
write ('Введите кол-во чисел: ');
readln (n);
setLength (a, n);
for i:=0 to n-1 do
begin
write ('Введите ', i+1, ' число: ');
readln (a[i]);
end;
for i:=0 to n-1 do
begin
writeln ('-----------------------');
writeln ('Число ', a[i], ':');
if (a[i] mod 2) = 0 then writeln ('Четное') else writeln ('Нечетное');
if (a[i] mod 3) = 0 then writeln ('Кратно 3-ем') else writeln ('Не кратно 3-ем');
if (a[i]<10) or (a[i]>99) then writeln ('Не 2-значное') else writeln ('2-значное');
end;
end.
var
a: array of int64;
n: longint;
i : byte;
begin
write ('Введите кол-во чисел: ');
readln (n);
setLength (a, n);
for i:=0 to n-1 do
begin
write ('Введите ', i+1, ' число: ');
readln (a[i]);
end;
for i:=0 to n-1 do
begin
writeln ('-----------------------');
writeln ('Число ', a[i], ':');
if (a[i] mod 2) = 0 then writeln ('Четное') else writeln ('Нечетное');
if (a[i] mod 3) = 0 then writeln ('Кратно 3-ем') else writeln ('Не кратно 3-ем');
if (a[i]<10) or (a[i]>99) then writeln ('Не 2-значное') else writeln ('2-значное');
end;
end.
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 33
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
