Вопрос задан 19.03.2019 в 19:16.
Предмет Информатика.
Спрашивает Кузовлев Павел.
Пожалуйста, помогите написать программу или хотя бы объясните, что от меня вообще хотят....Найти
количество элементов к каждому столбцу прямоугольной вещественной матрицы, меньших среднего арифметического всех элементов, рассмотренного столбца.Ответы на вопрос
Отвечает Власова Анна.
var a:array [byte,byte] of real;
i,j,n,m:byte;
s:real;
d,p:word;
begin
write('Введите количество строк n = ');readln(n);
write('Введите количество строк m = ');readln(m);
for i:=1 to n do
for j:=1 to m do
readln(a[i,j]);
s:=0;d:=0;p:=0;
for i:=1 to m do begin
for j:=1 to n do
s:=s+a[j,i];
for j:=1 to n do
if a[j,i]<(s/n) then inc(d);
writeln('Количество элементов в столбце ',i,' прямоугольной вещественной матрицы, меньших среднего арифметического d = ',d,' Среднее арифметическое = ',(s/n):0:4);
p:=p+d;
d:=0;s:=0;
end;
writeln('Общее количество элементов меньших элементов в столбцах = ',p);
writeln('Матрица');
for i:=1 to n do begin
for j:=1 to m do
write(a[i,j],' ');
writeln;
end;
end.
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 33
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
