Вопрос задан 05.05.2018 в 02:49.
Предмет Информатика.
Спрашивает Мушкет Владислав.
Помогите составить программу на языке паскаль S=2+4+6...+n
Ответы на вопрос
Отвечает Гимейн Миша.
Var s, i, n: integer;
begin
read(n);
i:=2;
write('S = ');
while (i<=n) do
begin
s:=s+i;
i:=i+2;
end;
writeln(s);
end.
Отвечает Евтушенко Илья.
Var
i,n,s:longint;
begin
Write('Введите четное значение последнего члена ряда: ');
Readln(n);
s:=0;
for i:=1 to n div 2 do s:=s+2*i;
Writeln('Сумма членов ряда равна ',s)
end.
Тестовое решение:
Введите четное значение последнего члена ряда: 50
Сумма членов ряда равна 650
Топ вопросов за вчера в категории Информатика
Информатика 16
Информатика 13
Информатика 39
Информатика 160
Информатика 65
Информатика 44
Информатика 84
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
