Вопрос задан 18.03.2019 в 09:14.
Предмет Информатика.
Спрашивает Александров Данил.
Помогите пожалуйста!!!!Дан массив, состоящий из целых чисел. Напишите программу, которая
подсчитывает количество положительных чисел среди элементов массива. Входные данные Сначала задано число N — количество элементов в массиве (1N10000). Далее через пробел записаны N чисел — элементы массива. Массив состоит из целых чисел. Выходные данные Необходимо единственное число - количество положительных элементов в массиве. Примеры: входные данные 5 1 2 3 -1 -4 Выходные данные 3Ответы на вопрос
Отвечает Краус Денис.
Pascal:
var i,n,kol:longint; a:array[1..10000] of longint;
begin
readln(n);
for i:=1 to n do begin
read(a[i]);
if a[i]>0 then inc(kol);
writeln(kol);
end.
var i,n,kol:longint; a:array[1..10000] of longint;
begin
readln(n);
for i:=1 to n do begin
read(a[i]);
if a[i]>0 then inc(kol);
writeln(kol);
end.
Отвечает Евсеева Алёна.
Program mas;
const nn=10000;
var
m: array[1..nn] of integer;
i,k,n: integer;
begin
writeln('Введите размерность массива'); readln(n);
k:=0;
for i:=1 to n do read(m[i]);
for i:=1 to n do
if m[i]>0 then k:=k+1;
writeln(k);
end.
const nn=10000;
var
m: array[1..nn] of integer;
i,k,n: integer;
begin
writeln('Введите размерность массива'); readln(n);
k:=0;
for i:=1 to n do read(m[i]);
for i:=1 to n do
if m[i]>0 then k:=k+1;
writeln(k);
end.
Топ вопросов за вчера в категории Информатика
Информатика 47
Информатика 26
Информатика 32
Информатика 70
Информатика 43
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
