Вопрос задан 17.03.2019 в 20:17.
Предмет Информатика.
Спрашивает Євдокімов Єгор.
Найти, есть ли данное число в массиве? Составить программу в с++
Ответы на вопрос
Отвечает Нургулжанов Ернур.
#include <iostream>
#include <cstdlib>
#include <vector>
using namespace std;
int main()
{
vector<int> v;
cout <<"Укажите размер массива: ";
int s;
cin >>s;
srand(time(0));
for(int i=0; i!=s; ++i)
v.push_back(rand()%100);
int find;
cout <<"Введите число для поиска: ";
cin >>find;
bool founded = false;
for(auto it=v.begin(); it!=v.end(); ++it)
if(*it==find) founded=true;
if(founded)
cout <<"Это число есть в массиве!" <<endl;
else cout <<"Такого числа нет в мвссиве!" <<endl;
return 0;
}
#include <cstdlib>
#include <vector>
using namespace std;
int main()
{
vector<int> v;
cout <<"Укажите размер массива: ";
int s;
cin >>s;
srand(time(0));
for(int i=0; i!=s; ++i)
v.push_back(rand()%100);
int find;
cout <<"Введите число для поиска: ";
cin >>find;
bool founded = false;
for(auto it=v.begin(); it!=v.end(); ++it)
if(*it==find) founded=true;
if(founded)
cout <<"Это число есть в массиве!" <<endl;
else cout <<"Такого числа нет в мвссиве!" <<endl;
return 0;
}
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
