Вопрос задан 17.03.2019 в 11:59.
Предмет Информатика.
Спрашивает Хайруллина Лейсан.
Очень срочно! Нужна ваша помощь! Написать программу на паскале: сформировать матрицу и найти
наименьшее среди средних арифметических элементов ее столбцов.( В ответе достаточно рабочего кода)Ответы на вопрос
Отвечает Маляренко Владислав.
Const n=5; m=6;
var a: array [1..n,1..m] of integer;
sum,min,i,j:integer;
begin
Randomize;
writeln('---A:---');
for i:=1 to n do begin
for j:=1 to m do begin
a[i,j]:=Random(20)-10;
write(a[i,j]:6);
end;
writeln;
end;
writeln('Среднее арифм. столбцов:');
min:=100000;
for j:=1 to m do begin
sum:=0;
for i:=1 to n do sum:=sum+a[i,j];
write(sum/n:6:2);
if sum<min then min:=sum;
end;
writeln;
writeln('Min=',min/n:6:2);
end.
var a: array [1..n,1..m] of integer;
sum,min,i,j:integer;
begin
Randomize;
writeln('---A:---');
for i:=1 to n do begin
for j:=1 to m do begin
a[i,j]:=Random(20)-10;
write(a[i,j]:6);
end;
writeln;
end;
writeln('Среднее арифм. столбцов:');
min:=100000;
for j:=1 to m do begin
sum:=0;
for i:=1 to n do sum:=sum+a[i,j];
write(sum/n:6:2);
if sum<min then min:=sum;
end;
writeln;
writeln('Min=',min/n:6:2);
end.
Топ вопросов за вчера в категории Информатика
Информатика 2212
Информатика 15
Информатика 635
Информатика 18
Информатика 61
Информатика 56
Информатика 42
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
