Вопрос задан 16.03.2019 в 07:47.
Предмет Информатика.
Спрашивает Бағытжанова Дильназ.
Составить программу на паскале.Вычислить корни квадратного уравнения, заданного коэффициентами A,
B,C (предполагается, что а<>0 и что дискриминант уравнения неотрицателен)Ответы на вопрос
Отвечает Лошадкин Никита.
Var a,b,c,D,x1,x2:real;
begin
write('Введите коэффициенты a, b, c: ' );
readln(a,b,c);
D:= b*b-4*a*c;
if D>0 then
begin
x1:=(-b-sqrt(D))/2/a;
x2:=(-b+sqrt(D))/2/a;
writeln('Два корня: ',x1,' и ',x2)
end;
if D=0 then
begin
x1:=-b/2/a;
writeln('Один корень: ',x1)
end;
if D<0 then writeln('Корней нет')
end.
begin
write('Введите коэффициенты a, b, c: ' );
readln(a,b,c);
D:= b*b-4*a*c;
if D>0 then
begin
x1:=(-b-sqrt(D))/2/a;
x2:=(-b+sqrt(D))/2/a;
writeln('Два корня: ',x1,' и ',x2)
end;
if D=0 then
begin
x1:=-b/2/a;
writeln('Один корень: ',x1)
end;
if D<0 then writeln('Корней нет')
end.
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 33
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
