Вопрос задан 12.03.2019 в 14:41.
Предмет Информатика.
Спрашивает Макеева Виктория.
Составить программу расчета нормы полива в теплице (л/м) по формуле:M=0,1*h*d*(-),гдеh– высота слоя
грунта, см; d– объемная масса грунта, г/см3; W1 – рекомендуемая относительная влажность грунта, % ППВ; W2 – фактическая относительная влажность грунта, % ППВ. Фактическая относительная влажность грунта изменяется в пределах от 50 до 60 % ППВ с шагом 1 %.Ответы на вопрос
Отвечает Серебренникова Вероника.
//Если я правильно понял, то так...
var
d, h, w1, w2: integer;
function readvalue(s: string): integer;
var t: integer;
begin
write(s, ' ');
readln(t);
result := t;
end;
begin
h := readvalue('Высота слоя грунта:');
d := readvalue('Объём грунта:');
w1 := readvalue('Рек. влажность грунта:');
writeln('Вл. грунта | Норма полива');
for w2 := 50 to 60 do
writeln(w2:9, '% | ', 0.1*h*d*(w1-w2), ' л/м');
end.
var
d, h, w1, w2: integer;
function readvalue(s: string): integer;
var t: integer;
begin
write(s, ' ');
readln(t);
result := t;
end;
begin
h := readvalue('Высота слоя грунта:');
d := readvalue('Объём грунта:');
w1 := readvalue('Рек. влажность грунта:');
writeln('Вл. грунта | Норма полива');
for w2 := 50 to 60 do
writeln(w2:9, '% | ', 0.1*h*d*(w1-w2), ' л/м');
end.
Топ вопросов за вчера в категории Информатика
Информатика 16
Информатика 13
Информатика 39
Информатика 160
Информатика 65
Информатика 44
Информатика 84
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
