Вопрос задан 12.03.2019 в 05:10.
Предмет Информатика.
Спрашивает Коркин Данил.
Написать программу, которая запрашивает номер дня недели и выводит его название. Включить в
программу модуль CRT. Запрос и результат работы программы вывести в окнах разного цвета. Установить цвет символов по желанию.PASCALОтветы на вопрос
Отвечает Barbq-Junior Андрюха.
Uses Crt;
Procedure R(Nazvanie:string; Cvet:byte);
Begin
TextBackground(Cvet);
ClrScr;
GotoXY(WindowWidth div 2-Length(Nazvanie) div 2,WindowHeight div 2);
Write(Nazvanie);
End;
Var n:byte;
Begin
HideCursor;
TextBackground(0);
ClrScr;
TextColor(15);
GotoXY(WindowWidth div 2-12,WindowHeight div 2);
Write('Введите номер дня недели');
Case ReadKey of
'1':
R('Понедельник',4);
'2':
R('Вторник',14);
'3':
R('Среда',2);
'4':
R('Четверг',9);
'5':
R('Пятница',1);
'6':
R('Суббота',13);
'7':
R('Воскресенье',12);
else R('В неделе сейчас семь дней!',0);
End;
ReadKey
End.
Procedure R(Nazvanie:string; Cvet:byte);
Begin
TextBackground(Cvet);
ClrScr;
GotoXY(WindowWidth div 2-Length(Nazvanie) div 2,WindowHeight div 2);
Write(Nazvanie);
End;
Var n:byte;
Begin
HideCursor;
TextBackground(0);
ClrScr;
TextColor(15);
GotoXY(WindowWidth div 2-12,WindowHeight div 2);
Write('Введите номер дня недели');
Case ReadKey of
'1':
R('Понедельник',4);
'2':
R('Вторник',14);
'3':
R('Среда',2);
'4':
R('Четверг',9);
'5':
R('Пятница',1);
'6':
R('Суббота',13);
'7':
R('Воскресенье',12);
else R('В неделе сейчас семь дней!',0);
End;
ReadKey
End.
Топ вопросов за вчера в категории Информатика
Информатика 38
Информатика 45
Информатика 24
Информатика 39
Информатика 16
Информатика 30
Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
