Вопрос задан 11.03.2019 в 14:02.
Предмет Информатика.
Спрашивает Маслен Виктория.
Составить программу на Паскале для получения таблицы умножения в шестнадцатеричной системе
счисления с использованием типа переменной char, оператора Case и функции chr(z1+48) - для получения символьного значения цифры от 0 до 9 (где z1 – переменная для первой цифры произведения)Ответы на вопрос
Отвечает Хозяшева Ксюша.
Var
A,B:integer;
C,H:Char;
Begin
For B:= 1 to 15 do
Begin
For A:= 1 to 15 do
Begin
Case (A*B) mod 16 of
0:H:='0';
1..9:H:=Chr(((A*B)mod 16)+48);
10:H:='A';
11:H:='B';
12:H:='C';
13:H:='D';
14:H:='E';
15:H:='F';
End;
Case (A*B)div 16 of
0:C:='0';
1..9:C:=Chr(((A*B)div 16)+48);
10:C:='A';
11:C:='B';
12:C:='C';
13:C:='D';
14:C:='E';
15:C:='F';
End;
Write(C+H,' ')
End;
WriteLn
End
End.
A,B:integer;
C,H:Char;
Begin
For B:= 1 to 15 do
Begin
For A:= 1 to 15 do
Begin
Case (A*B) mod 16 of
0:H:='0';
1..9:H:=Chr(((A*B)mod 16)+48);
10:H:='A';
11:H:='B';
12:H:='C';
13:H:='D';
14:H:='E';
15:H:='F';
End;
Case (A*B)div 16 of
0:C:='0';
1..9:C:=Chr(((A*B)div 16)+48);
10:C:='A';
11:C:='B';
12:C:='C';
13:C:='D';
14:C:='E';
15:C:='F';
End;
Write(C+H,' ')
End;
WriteLn
End
End.
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 25
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
