Вопрос задан 09.03.2019 в 08:44.
Предмет Информатика.
Спрашивает Чуйкин Миша.
В массиве храниться информация о стоимости товаров. Составьте программу, которая определяет
стоимость самого дешевого товара и его индекс.Ответы на вопрос
Отвечает Мурзова Алёна.
Массив данных о стоимости товаров зададим в виде целочисленных констант
program primer_1;
const a: array[1..12] of integer = (170, 180, 25, 36, 750, 1, 45, 28, 39, 10, 11, 58);
i,min,k: integer;
begin
min:=a[1];
for i:=2 to 12 do if a[i]<min then
begin
min:=a[i];
k:=i;
write('минимальная стоимость ', min, ' индекс' ,k)
end.
Или скорее всего этот вариант
program primer_1;
var a: array[1..12] of integer;
i, min, k: integer;
begin
for i:=1 to 12 do read(a[i]);{Ввод стоимостей товаров}
min:=a[1];
k:=0;
for i:=2 to 12 do
if a[i]<min
then
begin
min:=a[i];
k:=i;
end;
write('мин. сто-мость ', min, ' индекс ' ,k)
end.
Топ вопросов за вчера в категории Информатика
Информатика 14
Информатика 24
Информатика 37
Информатика 17
Информатика 34
Информатика 14
Информатика 52
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
