Вопрос задан 05.03.2019 в 07:57.
Предмет Информатика.
Спрашивает Алексеева Анастасия.
Написать программу, которая заполняет массив из 6 элементов случайными неповторяющимися
целочисленными значениями от 1 до 49. После этого программа просит пользователя ввести 6 целых чисел от 1 до 49 (при вводе проверяется, что вводимое число соответствует данному условию; в противном случае число вводится повторно). Программа считает, сколько чисел из введённых пользователем оказалась в массиве, и выводит их количество на экран. Паскаль абс срочно без плагеата Program Loto; Uses Crt; Const lt = 49; (* количество шаров в лототроне *) shar = 6; (* количество выигрышных шаров*) Var lott : array [1..lt] of integer; i, nom : integer; Begin randomize; for i:=1 to lt do lott[i]:=i; i:=1; while i <= shar do begin nom := random(49)+1; if lott[nom] <> 0 then begin write(lott[nom], ‘ ’); lott[nom] := 0; i := i+1; end; end; writeln; End. это начало по этой программе сделатьОтветы на вопрос
Отвечает Пак София.
Program Loto;
Uses Crt;
Const lt = 49; (* количество шаров в лототроне *)
shar = 6; (* количество выигрышных шаров*)
Var lott,vyb : array [1..shar] of integer;
i, j, nom, k : integer;
m:set of byte;
Begin
randomize;
m:=[];
for i:=1 to shar do
begin
repeat
nom:=1+random(lt);
until not(nom in m);
lott[i]:=nom;
m:=m+[nom];
end;
writeln('Выберите шаров от 1 до 6 ',lt);
m:=[];
begin
repeat
write('nom',i,'=');
readln(nom);
until (nom in [1..lt])and not(nom in m);
vyb[i]:=nom;
m:=m+[nom];
end;
clrscr;
writeln('Номера шаров в лототроне');
for i:=1 to shar do write(lott[i]:3);
writeln;
writeln('Выбранные шары');
for i:=1 to shar do
write(vyb[i]:3);
writeln;
write('Совпавшие шары: ');
k:=0;
for i:=1 to shar do
for j:=1 to shar do
if lott[i]=vyb[j] then
begin
k:=k+1;
write(lott[i]:3);
end;
if k=0 then write('- нет')
else write(' Их количество=',k)
end.
Uses Crt;
Const lt = 49; (* количество шаров в лототроне *)
shar = 6; (* количество выигрышных шаров*)
Var lott,vyb : array [1..shar] of integer;
i, j, nom, k : integer;
m:set of byte;
Begin
randomize;
m:=[];
for i:=1 to shar do
begin
repeat
nom:=1+random(lt);
until not(nom in m);
lott[i]:=nom;
m:=m+[nom];
end;
writeln('Выберите шаров от 1 до 6 ',lt);
m:=[];
begin
repeat
write('nom',i,'=');
readln(nom);
until (nom in [1..lt])and not(nom in m);
vyb[i]:=nom;
m:=m+[nom];
end;
clrscr;
writeln('Номера шаров в лототроне');
for i:=1 to shar do write(lott[i]:3);
writeln;
writeln('Выбранные шары');
for i:=1 to shar do
write(vyb[i]:3);
writeln;
write('Совпавшие шары: ');
k:=0;
for i:=1 to shar do
for j:=1 to shar do
if lott[i]=vyb[j] then
begin
k:=k+1;
write(lott[i]:3);
end;
if k=0 then write('- нет')
else write(' Их количество=',k)
end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
