Вопрос задан 02.05.2018 в 06:46. Предмет Информатика. Спрашивает Яковлев Андрей.

Написать программу нахождения суиммы большего и меньшего из 3 чисел

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Токтасынов Азамат.

#include <iostream>
#include <cmath>
using namespace std;

int main()
{
 int selection;
 float first, second, result;
 cout << "Калькулятор\n";
 cout << "1. Сложение\n";
 cout << "2. Вычитание\n";
 cout << "3. Умножение\n";
 cout << "4. Деление\n";
 cout << "0. О программе\n\n";
 cout << "Введите цифру: ";
 cin >> selection;
 switch(selection)
 {
  case 1:
   cout << "Введите первое слагаемое: ";
   cin >> first;
   cout << "Введите второе слагаемое: ";
   cin >> second;
   result = first + second;
   cout << "Результат: " << result << "\n";
   break;
  case 2:
   cout << "Введите уменьшаемое: ";
   cin >> first;
   cout << "Введите вычитаемое: ";
   cin >> second;
   result = first - second;
   cout << "Результат: " << result << "\n";
   break;
  case 3:
   cout << "Введите первый множитель: ";
   cin >> first;
   cout << "Введите второй множитель: ";
   cin >> second;
   result = first * second;
   cout << "Результат: " << result << "\n";
   break;
  case 4:
   cout << "Введите делимое: ";
   cin >> first;
   cout << "Введите делитель: ";
   cin >> second;
   result = first / second;
   cout << "Результат: " << result << "\n";
   break;
  case 0:
   cout << "Программа 'Калькулятор'.\n";
   break;
  default:
   cout << "Необходимо ввести цифру от 0 до 4 в зависимости от Вашего выбора!\n";
 }
return 0;
}

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос