Вопрос задан 03.03.2019 в 09:06.
Предмет Информатика.
Спрашивает Иванов Владислав.
Составить программу для нахождения наибольшего из 3 чисел.
Ответы на вопрос
Отвечает Екимов Илья.
var
a, b, c : longint;function nod3 (a, b, c :longint) : longint;
begin
nod3 := nod (nod (a, b), c);
end;function nod(var a, b: longint): longint;
begin
if (a = 0) or (b = 0) then
if a = 0 then
nod:= b
else
nod:= a
else
if a >= b then
nod:= nod( a mod b, b)
else
nod:= nod( a, b mod a)
end;begin
read (a, b, c);
writeln (nod3 (a, b, c));
end.
Топ вопросов за вчера в категории Информатика
Информатика 14
Информатика 24
Информатика 37
Информатика 17
Информатика 34
Информатика 14
Информатика 52
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
