Вопрос задан 01.03.2019 в 15:03. Предмет Информатика. Спрашивает Самосадкина Арина.

Написать программу,которая определяет количество всех чисел из диапазона от 5 до 25.(Паскаль)

Входные данные:1,6,35,12,18,24,0.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Ширинбекова Аружан.

Program Summa;

Uses Crt;

var s,n,c:integer;

 

 begin

   clrscr;

   write('Введите числа коннц ввода 0: ');

    s:=0;c:=0; 

    repeat

        readln(n);

        c:=c+1; 

if (n mod 2)=0 then
      if ((n>=5)and (n<=25)) then s:=s+n;        

  until (n=0) or (c=1000) ;    

write('Сумма ',c,' чётных чисел в диапазоне от 5 до 25:',s);

   readkey;

 

end. 
:D

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа на языке Pascal для определения количества чисел из диапазона от 5 до 25

```pascal program CountNumbersInRange;

var numbers: array[1..7] of Integer = (1, 6, 35, 12, 18, 24, 0); count: Integer; i: Integer;

begin count := 0;

for i := 1 to Length(numbers) do begin if (numbers[i] >= 5) and (numbers[i] <= 25) then count := count + 1; end;

writeln('Количество чисел из диапазона от 5 до 25: ', count); end. ```

Объяснение программы

1. В данной программе мы используем массив `numbers`, в котором содержатся входные данные: 1, 6, 35, 12, 18, 24, 0. 2. Мы инициализируем переменную `count` со значением 0, которая будет использоваться для подсчета количества чисел из диапазона от 5 до 25. 3. Затем мы используем цикл `for` для перебора всех элементов массива `numbers`. 4. Внутри цикла мы проверяем, находится ли текущий элемент в диапазоне от 5 до 25 с помощью условия `(numbers[i] >= 5) and (numbers[i] <= 25)`. 5. Если условие выполняется, то увеличиваем значение переменной `count` на 1. 6. По завершении цикла выводим результат подсчета с помощью процедуры `writeln`.

Результат выполнения программы

При выполнении данной программы с входными данными 1, 6, 35, 12, 18, 24, 0, программа выведет следующий результат:

``` Количество чисел из диапазона от 5 до 25: 4 ```

Примечание: В данной программе мы предполагаем, что входные данные уже заданы в массиве `numbers`. Если вам нужно вводить данные с клавиатуры, вы можете использовать процедуру `readln` для считывания значений в массив.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос