РЕШИТЕ ЗАДАЧУ В ПАСКАЛЕ,ПОЖАЛУЙСТА! напишите программу,которая заполняет массив из N элементов
случайными целыми числами в диапазоне [A,B] и определяет количество элементов этого массива,у которых сумма цифр равна K.Ответы на вопрос
// Внимание! Если программа не работает, обновите версию!
function sn(n:integer):integer; // сумма цифр числа
begin
n:=Abs(n);
Result:=0;
while n>0 do begin
Result+=n mod 10;
n:=n div 10
end
end;
begin
var (n,a,b):=ReadInteger3('Введите n,a,b через пробел:');
var m:=ArrRandom(n,a,b); m.Println;
var k:=ReadInteger('k=');
Writeln('Найдено чисел: ',m.Where(t->sn(t)=k).Count)
end.
Пример
Введите n,a,b через пробел: 15 -50 60
43 2 42 -26 -34 57 45 44 29 -41 -4 1 -17 38 -19
k= 7
Найдено чисел: 2
Задача: Заполнение массива случайными числами и подсчет элементов с заданной суммой цифр
Для решения данной задачи вам потребуется написать программу на языке Pascal, которая будет заполнять массив из N элементов случайными целыми числами в заданном диапазоне [A, B] и определять количество элементов этого массива, у которых сумма цифр равна K.
Вот пример программы на Pascal, которая решает данную задачу:
```pascal program RandomArray;
const N = 10; // количество элементов в массиве A = 1; // начало диапазона B = 100; // конец диапазона K = 5; // сумма цифр
var arr: array[1..N] of integer; count: integer; i, num, digitSum: integer;
// Функция для подсчета суммы цифр числа function SumOfDigits(num: integer): integer; var sum, digit: integer; begin sum := 0; while num > 0 do begin digit := num mod 10; sum := sum + digit; num := num div 10; end; SumOfDigits := sum; end;
begin // Заполняем массив случайными числами randomize; for i := 1 to N do arr[i] := random(B - A + 1) + A;
// Подсчитываем количество элементов с заданной суммой цифр count := 0; for i := 1 to N do begin digitSum := SumOfDigits(arr[i]); if digitSum = K then count := count + 1; end;
// Выводим результаты writeln('Массив случайных чисел:'); for i := 1 to N do write(arr[i], ' '); writeln; writeln('Количество элементов с суммой цифр равной ', K, ': ', count); end. ```
В данной программе мы используем переменные `N`, `A`, `B` и `K` для задания параметров задачи. Вы можете изменить эти значения в соответствии с вашими требованиями.
Программа сначала заполняет массив `arr` случайными числами в диапазоне [A, B]. Затем она подсчитывает количество элементов массива, у которых сумма цифр равна K, используя функцию `SumOfDigits` для подсчета суммы цифр каждого числа.
Наконец, программа выводит массив случайных чисел и количество элементов с заданной суммой цифр.
Примечание: Пожалуйста, учтите, что Pascal является устаревшим языком программирования, и его использование не рекомендуется для новых проектов. Рекомендуется использовать более современные языки программирования, такие как Python, Java или C++.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
