Составить программу на паскалем, которая выводит на экран максимальное число из трех вводимых
Ответы на вопрос
function max(a, b : integer) : integer;
begin
if a>b then max:=a
else max:=b;
end;
begin
readln(a, b, c);
writeln(max(max(a, b),c));
end.
Вот пример программы на языке Pascal, которая выводит на экран максимальное число из трех вводимых:
```pascal program MaxNumber;
var num1, num2, num3, max: integer;
begin // Вводим три числа writeln('Введите первое число:'); readln(num1); writeln('Введите второе число:'); readln(num2); writeln('Введите третье число:'); readln(num3); // Определяем максимальное число max := num1; if num2 > max then max := num2; if num3 > max then max := num3; // Выводим максимальное число writeln('Максимальное число: ', max); end. ```
Программа запрашивает у пользователя ввод трех чисел и затем определяет максимальное из них, используя несколько условных операторов if. Наконец, программа выводит максимальное число на экран.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
