Вопрос задан 01.03.2019 в 03:51. Предмет Информатика. Спрашивает Гайсов Наис.

Напишите программу для записи в файл десяти чисел вводимых с клавиатуры.

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Королев Максим.
Var f:text ;
c:array [1..10] of integer;
i:integer;
begin
for i:=1 to 10 do begin 
writeln ('Введите ',i,' число');
read(c[i]);
end;
assign (f,'res.txt');
rewrite(f);
for i:=1 to 10 do
write (f,' ',c[i]);
close (f);
end.

Писал на Pascal ABC. Для того, чтобы работала, тебе нужно создать папку, и в этой папке сохранить данную программу. После запуска, тебе нужно будет ввести 10 чисел. Результат сохранится в той папке, в которой будет сохранена программа !
0 0
Отвечает Филатова Аля.
Var
  i, temp :integer;
begin
  assign(output, 'output.txt'); rewrite(output);
  for i to 10 do begin
    read(temp);
    write(temp);
  end;
end.
файл output.txt должен быть создан. 
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Чтобы создать программу для записи 10 чисел, введенных с клавиатуры, в файл, вы можете использовать следующий код на языке Python:

```python # Открываем файл для записи file = open("numbers.txt", "w")

# Цикл для записи 10 чисел for i in range(10): number = input("Введите число: ") file.write(str(number) + "\n")

# Закрываем файл file.close() ```

В этом коде мы сначала открываем файл "numbers.txt" для записи с помощью функции open() и режима "w". Затем мы запускаем цикл, который будет выполняться 10 раз. Внутри цикла мы просим пользователя ввести число с помощью функции input() и сохраняем его в переменную number. Затем мы записываем это число в файл с помощью метода write(). Преобразуем число в строку с помощью функции str(), потому что метод write() принимает только строки. Мы также добавляем символ новой строки "\n" после каждого числа, чтобы каждое число было записано на новой строке. После выполнения цикла мы закрываем файл с помощью метода close(). Это важно, потому что файл должен быть закрыт после завершения операций записи.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос