 
Составьте программу к задачам. 1. Программа пожарного датчика, который выводит сообщение «Пожарная
ситуация», если температура в комнате превышает 600С. В противном случае выводится информация «Рабочая ситуация». (полный условный оператор). 2. Программа, которая по номеру дня недели выдает количество уроков в вашем классе (неполный условный оператор) 0
        0
         0
        0
    Ответы на вопрос
 
        Begin
var a,b:integer;
WriteLN('Введите градус: ');
ReadLN(a);
if a > 600 then begin
WriteLN('Пожарная ситуация')
end;
if b < 600 then begin
WriteLN('Рабочая ситуация')
end;
end.
2)
Begin var a:integer;
WriteLN('Введите номер дня недели: ');
ReadLN(a);
if a = 1 then begin
WriteLN('Понедельник-Количество уроков: 6')
end;
if a = 2 then begin
WriteLN('Вторник-Количество уроков: 6')
end;
if a = 3 then begin
WriteLN('Среда-Количество уроков: 6')
end;
if a = 4 then begin
WriteLN('Четверг-Количество уроков: 6')
end;
if a = 5 then begin
WriteLN('Пятница-Количество уроков: 6')
end;
if a = 6 then begin
WriteLN('Суббота-Количество уроков: 6')
end;
end.
 0
                    0
                     0
                    0
                 
            1. Программа пожарного датчика:
``` // Входные данные - температура в комнате float temperature = 620;
// Проверка условия с помощью полного условного оператора if (temperature > 600) { // Вывод сообщения о пожарной ситуации System.out.println("Пожарная ситуация"); } else { // Вывод сообщения о рабочей ситуации System.out.println("Рабочая ситуация"); }
// Программа завершается ```
2. Программа, которая по номеру дня недели выдает количество уроков в вашем классе:
``` // Входные данные - номер дня недели int dayOfWeek = 3;
// Проверка условия с помощью неполного условного оператора if (dayOfWeek == 1 || dayOfWeek == 2 || dayOfWeek == 4 || dayOfWeek == 5 || dayOfWeek == 6) { // Вывод количества уроков в обычный день System.out.println("В вашем классе 6 уроков"); } else if (dayOfWeek == 3) { // Вывод количества уроков в среду System.out.println("В вашем классе 4 урока"); } else { // Вывод количества уроков в воскресенье System.out.println("Воскресенье - выходной день"); }
// Программа завершается ```
В обоих программах используется условный оператор `if` для проверки заданных условий и вывода соответствующей информации в зависимости от результата проверки. В первой программе используется полный условный оператор, а во второй - неполный условный оператор.
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			