Вопрос задан 28.02.2019 в 17:05. Предмет Информатика. Спрашивает Фёдоров Виктор.

Pascal составить прграмму . Работа светофора запрограммирована таким образом : в начале каждого

часа 3 минуты горит зелёный свет , затем 2 минуты красный , затем 3 минуты зелёный и т.д . Дано время t в минутах от начала часа . Определить сигнал какого цвета горит в этот момент времени для пешехода .
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Манойлова Ксения.
Var a:integer;
begin
  writeln('Введите время (в минутах)');
  readln(a);
  if ((a mod 10>=0)and(a mod 10< 3))or((a mod 10>=5)and(a mod 10< 8)) then writeln('Зелёный')
  else writeln('Красный');
  readln
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения данной задачи вам понадобится использовать арифметические операции и условные операторы в языке программирования Pascal.

Вот пример программы на Pascal, которая решает эту задачу:

```pascal program TrafficLight;

var t: integer;

begin writeln('Введите время t в минутах от начала часа:'); readln(t); // Определение сигнала светофора для пешехода if (t mod 5) < 3 then writeln('Сейчас горит зеленый свет') else writeln('Сейчас горит красный свет'); readln; end. ```

В данной программе мы сначала считываем значение переменной `t` - время в минутах от начала часа. Затем, используя операцию взятия остатка от деления (`mod`), определяем остаток от деления времени на 5. Если остаток меньше 3, то выводим сообщение "Сейчас горит зеленый свет", иначе - "Сейчас горит красный свет".

Например, если пользователь вводит время `7`, то программа выведет "Сейчас горит зеленый свет", так как остаток от деления 7 на 5 равен 2, что меньше 3.

Надеюсь, эта информация поможет вам составить программу на Pascal для решения данной задачи.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос