ПОМОГИТЕ ЭТО ОЧЕНЬ ВАЖНО! fpc - Free Pascal 2.6.2-8 gcc - GNU C 4.8.2 python - Python 2.7.6 javac -
Java JDK 1.7.0_45 python3 - Python 3.4.0 Недавно Король побывал с официальным визитом в городе L. и под впечатлениями от города решил в своем Королевстве тоже развивать туризм. С этой целью уже закуплено несколько экипажей и принят проект создания Центральной Конной станции (ЦКС). Однако, две большие проблемы мешают начать реализацию проекта. Во-первых, в Королевстве не так много площадок для карет (большая часть территории занята тюльпанами Королевы-бабушки, а она ни за что не позволит их забрать). Во-вторых, ни в семье, ни в администрации Короля не могут договориться, на каком из площадок строить ЦКС. Королева хочет, чтобы он был как можно ближе к ее оранжереи и все гости видели волшебные деревья. Принцесса настаивает, чтобы ЦКС сооружали у Театра, которым она так восхищается. Принц считает жемчужиной Королевства его гольф-клуб, Секретарь Короля - новый ресторан и т.д ... Король уже запутался с расчетами и попытками найти компромиссное решение. Мудрый Советник предложил выбрать для ЦКС то из площадок, от которого расстояние до самого дальнего из важных Королевских Объектов будет наименьшей. Король согласился с решением Советника, но не знает как определить, на каком из площадок строить ЦКС. Поможем Королю? Входные данные (вводятся с клавиатуры): В первой строке одно целое число N (1 ≤ N ≤ 500), что задает количество Королевских Объектов, которые нужно учитывать в выборе площадки ЦКС. В следующих N строках по два действительных числа, задающие координаты (x и y) каждого из объектов. Далее в отдельной строке одно целое число M (1 ≤ M ≤ 100), что указывает количество возможных точек расположения ЦКС. В следующих M строках по два действительных числа, задающие координаты (x и y) каждой площадки. Примечание: упрощенно считаем, что дороги от каждого из площадок ко всем объектам прямолинейны. Результат: Одно целое число n (1 ≤ n ≤ N), задающее номер выбранного для ЦКС площадки (расстояние до самого дальнего из объектов от этой площадки должно быть наименьшим среди всех площадок).Ответы на вопрос
Var
arnx,armx,arny,army,delMmax:array[1..1000] of real;
N,M,res,i,j:integer;
min:real;
begin
min:=maxreal;
{не уверен существует ли эта константа в fpc, если что, она равна максимальному значению типа real}
readln(N);
for i:=1 to N do
readln(arnx[i],arny[i]);
readln(M);
for i:=1 to M do
begin
readln(armx[i],army[i]);
delMmax[i]:=-1;
for j:=1 to N do
if delMmax[i]<sqrt(sqr(armx[i]-arnx[j])+sqr(army[i]-arny[j]))
then
delMmax[i]:=sqrt(sqr(armx[i]-arnx[j])+sqr(army[i]-arny[j]));
if delMmax[i]<min
then
begin
min:=delMmax[i];
res:=i;
end;
end;
writeln(res);
end.
Пример ввода:
3
2 1
1 2
1 1
3
1 5
3 3
4 2
Пример вывода:
2
Based on the information provided, it seems that you are looking for assistance with a programming problem related to determining the optimal location for a Central Equestrian Station (Центральная Конная станция, ЦКС) in a kingdom. The goal is to choose a location for the ЦКС that minimizes the distance to the farthest Royal Object (Королевский Объект) among a given set of objects.
To solve this problem, you can use a distance calculation algorithm to find the distance between each potential ЦКС location and all the Royal Objects. Then, you can select the ЦКС location that has the smallest distance to the farthest Royal Object.
Here is a step-by-step approach to solving this problem:
1. Read the input: - Read the number of Royal Objects, N. - Read the coordinates (x and y) of each Royal Object. - Read the number of potential ЦКС locations, M. - Read the coordinates (x and y) of each potential ЦКС location.
2. Calculate the distances: - For each potential ЦКС location, calculate the distance to each Royal Object. - Store the distances in a suitable data structure, such as a list or an array.
3. Find the optimal ЦКС location: - Iterate through the distances and find the maximum distance for each potential ЦКС location. - Keep track of the minimum maximum distance and the corresponding ЦКС location.
4. Output the result: - Print the index of the ЦКС location with the minimum maximum distance.
Please note that the code implementation for this problem is not provided in the question. However, the steps outlined above should guide you in solving the problem. If you need further assistance with the code implementation, please provide the code you have tried, and I will be happy to help you debug or optimize it.
Let me know if you have any further questions or need additional clarification!
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
