Вопрос задан 27.02.2019 в 13:26. Предмет Информатика. Спрашивает Базикова Полина.

Помогите с заданием на языке Pascal Используя оператор условного перехода, напишите программу,

которая: запрашивает с клавиатуры два целых числа, их сумму и произведение и выводит на экран сооб- щение о правильности сделанных пользователем вычислений;
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Калимулина Лилия.
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var (a,b):=ReadReal2('Введите два числа через пробел:');
  var (s1,p1):=ReadReal2('Введите через пробел из сумму и произведение:');
  var (s2,p2):=(a+b,a*b);
  if s1=s2 then Writeln('Сумма верна')
  else Writeln('Сумма не верна, ',s2);
  if p1=p2 then Writeln('Произведение верно')
  else Writeln('Произведение не верно, ',p2)
end.

Пример
Введите два числа через пробел: 1.4 -2.5
Введите через пробел из сумму и произведение: -1.1 -3.25
Сумма верна
Произведение не верно, -3.5
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на языке Pascal, которая выполняет указанное задание:

```pascal program Calculator;

var num1, num2, sum, product: integer;

begin // Запрашиваем у пользователя два целых числа write('Введите первое целое число: '); readln(num1);

write('Введите второе целое число: '); readln(num2);

// Вычисляем сумму и произведение sum := num1 + num2; product := num1 * num2;

// Выводим результаты на экран writeln('Сумма введенных чисел: ', sum); writeln('Произведение введенных чисел: ', product);

// Проверяем условие и выводим соответствующее сообщение if (sum = num1 + num2) and (product = num1 * num2) then writeln('Правильные вычисления!') else writeln('Ошибка в вычислениях!');

readln; // Чтобы консольное окно не закрылось сразу end. ```

Программа сначала запрашивает у пользователя два целых числа, затем вычисляет и выводит их сумму и произведение. После этого она проверяет, правильно ли пользователь выполнил вычисления, и выводит соответствующее сообщение.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос