Ввести массив из 10 положительных чисел. Программа должна посчитать количество чисел, которые
делятся на 2 или на 3. Написать программу PascalABC.Ответы на вопрос
begin
for var i:=1 to 10 do
read(a[i]);
var s:=a.Where(t->((t mod 2=0) or (t mod 3=0)));
Writeln('Кол-во: ',s.Count)
end.
Конечно, вот пример программы на PascalABC, которая решает вашу задачу:
```pascal program CountDivisibleBy2Or3;
var numbers: array[1..10] of integer; // массив из 10 положительных чисел count: integer; // переменная для хранения количества чисел, делящихся на 2 или 3 i: integer; // переменная для цикла
begin // Вводим массив из 10 положительных чисел writeln('Введите 10 положительных чисел:'); for i := 1 to 10 do begin write('Число ', i, ': '); readln(numbers[i]); end;
// Инициализируем счетчик count := 0;
// Проверяем каждое число в массиве for i := 1 to 10 do begin // Проверяем, делится ли число на 2 или на 3 if (numbers[i] mod 2 = 0) or (numbers[i] mod 3 = 0) then begin // Если делится, увеличиваем счетчик count := count + 1; end; end;
// Выводим результат writeln('Количество чисел, делящихся на 2 или на 3: ', count);
// Ждем ввода перед закрытием окна readln; end. ```
Программа сначала запрашивает ввод 10 положительных чисел, затем проверяет каждое число в массиве и увеличивает счетчик, если число делится на 2 или на 3. В конце программа выводит количество чисел, которые удовлетворяют условию.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
