. Напишите программу в паскале, которая меняет местами значения целых переменных M и N без
использования дополнительной переменной. Ниже представлен рекомендуемый вид экрана во время работы программы (данные вводимые пользователем выделены полужирным шрифтом). Введите число M=> 5 Ведите число N=> 7 ----------------------- Новые значения: M=7, N=5Ответы на вопрос
Программа на языке Паскаль, которая меняет местами значения целых переменных M и N без использования дополнительной переменной, может выглядеть следующим образом:
```pascal program SwapVariables; var M, N: Integer;
begin writeln('Введите число M => '); readln(M); writeln('Введите число N => '); readln(N);
writeln('-----------------------'); writeln('Новые значения: M=', N, ', N=', M); end. ```
Пользователю предлагается ввести значения переменных M и N. Затем выводится сообщение с новыми значениями переменных, которые получены после их обмена местами.
Например, при вводе числа M=5 и числа N=7, программа выведет следующий результат:
``` Введите число M => 5 Введите число N => 7 ----------------------- Новые значения: M=7, N=5 ```
Таким образом, значения переменных M и N меняются местами без использования дополнительной переменной.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
