Паскаль АВС. Дана строка символов. Составьте программу которая подсчитывает, сколько в данной
строке слов оканчивающихся на а. Все слова разделяются 1 пробелом и только русские буквы.Ответы на вопрос
s: string;
i, n: integer;
a: set of char;
begin
Writeln('Введите строку текста');
Readln(s);
n := 0;
a := ['А', 'а'];
for i := 1 to Length(s) do
if (s[i] = ' ') and (s[i - 1] in a) then n := n + 1;
if (s[i - 1] in a) then n := n + 1;
Writeln('Количество слов, оканчивающихся буквой "а", равно ', n)
end.
Тестовое решение:
Введите строку текста
А роза упала на лапу Азора
Количество слов, оканчивающихся буквой "а", равно 4
Конечно, вот пример программы на языке Pascal, которая подсчитывает количество слов в строке, оканчивающихся на букву "а":
```pascal program CountWordsEndingWithA;
uses SysUtils;
function CountWordsEndingWithA(inputString: string): Integer; var words: TStringDynArray; word: string; count, i: Integer; begin count := 0; // Разделение строки на слова по пробелам words := SplitString(inputString, ' ');
for i := 0 to Length(words) - 1 do begin word := words[i];
// Проверка, заканчивается ли слово на букву "а" (как заглавную, так и строчную) if (Length(word) > 0) and ((word[Length(word)] = 'а') or (word[Length(word)] = 'А')) then Inc(count); end;
CountWordsEndingWithA := count; end;
var inputText: string; wordsEndingWithA: Integer; begin // Ввод строки пользователем Write('Введите строку: '); ReadLn(inputText);
// Подсчет слов, оканчивающихся на "а" wordsEndingWithA := CountWordsEndingWithA(inputText); // Вывод результата WriteLn('Количество слов, оканчивающихся на "а": ', wordsEndingWithA); end. ```
Эта программа определяет функцию `CountWordsEndingWithA`, которая принимает вводную строку и возвращает количество слов, оканчивающихся на букву "а". Она использует встроенную функцию `SplitString` из модуля `SysUtils`, чтобы разделить входную строку на отдельные слова, разделенные пробелами. Затем она проверяет каждое слово на наличие окончания на букву "а" (как заглавную, так и строчную) и подсчитывает соответствующие слова.
Программа запрашивает ввод строки от пользователя, подсчитывает количество слов, удовлетворяющих условию, и выводит результат.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
