 
Напишите программу для вычисления n-й степени числа x. вычисление описать каждым из трех вариантов
оператора цикла: For...to...do,While...do,Repeat...until. 0
        0
         0
        0
    Ответы на вопрос
 
        Program ANT;
var x,F:real;
var n:integer;
begin
writeln('Введите x');
readln(x);
writeln('Введите n');
readln(n);
while x>=0 do begin
F:=exp(n*ln(x));
write('F=');
writeln(f:4:2);
end;
readln;
end.
 0
                    0
                     0
                    0
                 
            Конечно, давайте напишем программу для вычисления n-й степени числа x, используя три варианта операторов цикла: `for...to...do`, `while...do`, и `repeat...until` на языке программирования Pascal.
Используя оператор цикла `for...to...do`:
```pascal program PowerCalcFor;
var x, result: real; n, i: integer;
begin write('Введите число x: '); readln(x);
write('Введите степень n: '); readln(n);
result := 1;
for i := 1 to n do begin result := result * x; end;
writeln('Результат: ', result); end. ```
Используя оператор цикла `while...do`:
```pascal program PowerCalcWhile;
var x, result: real; n, i: integer;
begin write('Введите число x: '); readln(x);
write('Введите степень n: '); readln(n);
result := 1; i := 1;
while i <= n do begin result := result * x; Inc(i); end;
writeln('Результат: ', result); end. ```
Используя оператор цикла `repeat...until`:
```pascal program PowerCalcRepeat;
var x, result: real; n, i: integer;
begin write('Введите число x: '); readln(x);
write('Введите степень n: '); readln(n);
result := 1; i := 1;
repeat result := result * x; Inc(i); until i > n;
writeln('Результат: ', result); end. ```
Выберите тот вариант, который наилучшим образом соответствует вашим требованиям или требованиям языка программирования, который вы используете.
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			