
Вопрос задан 23.02.2019 в 21:17.
Предмет Информатика.
Спрашивает Макаров Ньургун.
Напишите программу на языке паскаль, которая генерирует 10 случайных чисел в диапазоне от 1 до 20,
выводит эти числа на экран и вычисляет их среднее арифметическое.

Ответы на вопрос

Отвечает Кузнецов Никита.
Var a,i,b:integer;
s:real;
begin
a:=0;
for i:=1 to 10 do begin
b:=random(20)+1;
a+=b;
write(b,' ');
end;
writeln;
s:=a/10;
writeln(s);
end.
s:real;
begin
a:=0;
for i:=1 to 10 do begin
b:=random(20)+1;
a+=b;
write(b,' ');
end;
writeln;
s:=a/10;
writeln(s);
end.



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Программа на языке Паскаль, которая генерирует 10 случайных чисел в диапазоне от


Топ вопросов за вчера в категории Информатика

Информатика 565

Информатика 25

Информатика 22

Информатика 27

Информатика 34

Информатика 58

Информатика 63

Информатика 23
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili