Напишите программу в паскалях Мама в магазине купила А конфет по В рублей и D печениья по F
рублей. Сколько денег потратила мама?Ответы на вопрос
a, b, d, f, s1, s2: integer;
begin
Writeln('Сколько конфет купила мама?');
Readln(a);
Writeln('Сколько стоят конфеты?');
Readln(b);
Writeln('Сколько печенья купила мама?');
Readln(d);
Writeln('Сколько стоят печенья?');
Readln(f);
s1:=a*b;
s2:=d*f;
Writeln('Мама купила конфет на ', s1, ' рублей, а печенья на ', s2, ' рублей.');
Writeln('Всего мама потратила: ', s1+s2, ' рублей.');
end.
Конечно, давайте напишем простую программу на Pascal, которая решит эту задачу. Программа будет запрашивать у пользователя значения переменных A, В, и D, а затем вычислять общую сумму потраченных денег. Вот пример кода:
```pascal program CalculateExpenses;
var A, B, D: real; // Используем тип real для переменных с десятичными числами totalExpenses: real;
begin // Вводим значения переменных с клавиатуры writeln('Введите стоимость конфет (A) в рублях: '); readln(A);
writeln('Введите стоимость печенья (D) в рублях: '); readln(D);
// Вычисляем общую сумму потраченных денег totalExpenses := A + D;
// Выводим результат writeln('Мама потратила общую сумму в ', totalExpenses:0:2, ' рублей.'); end. ```
Обратите внимание, что в этой программе используется тип данных `real` для переменных, так как цены на продукты могут быть десятичными числами. Также в выводе результата используется форматирование `:0:2`, чтобы вывести два знака после запятой. Вы можете изменить тип данных или форматирование в зависимости от ваших конкретных требований.
Запустите этот код в среде программирования, поддерживающей Pascal, чтобы увидеть результат.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
