
Нужно написать программу на с++ мы вводим массив из букв, а программа должна их отсортировать по
алфавиту

Ответы на вопрос

#include <string>
using namespace std;
int main()
{
string S;
cin >> S;
int Mass[52];
for (int i = 0; i < 52; i++)
{
Mass[i] = 0;
}
for (int i = 0; i < S.length(); i++)
{
char c = S[i];
if (c >= 'a'&&c <= 'z')
{
Mass[(int)(c-'a')*2]++;
} else if (c >= 'A'&&c <= 'Z'){
Mass[(int)(c-'A')*2+1]++;
}
}
for (int i = 0; i < 52; i++)
{
for (int j = 0; j < Mass[i]; j++)
{
cout << (i % 2 == 0?(char)(i/2+'a'):(char)(i/2+'A'));
}
}
return 0;
}
Пример работы программы:
LKDKjgkjsdlfvkhnOLHDSKLJNFLjghlJNKSgbakjbjkHVLJhfvkjHVKJAyfjHLIhaLIUYGFLAkjbhdilAUGXIKJASILFYHGklajfbhliGFLKjblkJBDFIgiksjbnfowshKLJH
aaaAAAAbbbbbbBddDDDfffffFFFFFggggGGGGhhhhhhhHHHHHHiiiIIIIIjjjjjjjjjjjJJJJJJJkkkkkkkkkKKKKKKKKllllllLLLLLLLLLLLnnNNoOsssSSSUUvvVVwXyYY



Для сортировки массива букв по алфавиту в языке программирования C++ можно использовать функцию `std::sort` из стандартной библиотеки. Вот пример программы, которая сортирует массив букв:
```cpp
#include
int main() { char arr[] = {'d', 'b', 'a', 'c'}; int size = sizeof(arr) / sizeof(arr[0]);
std::sort(arr, arr + size);
std::cout << "Отсортированный массив: "; for (int i = 0; i < size; i++) { std::cout << arr[i] << " "; } std::cout << std::endl;
return 0; } ```
В этом примере мы объявляем массив `arr` и инициализируем его буквами в произвольном порядке. Затем мы используем функцию `std::sort` для сортировки массива. Функция `std::sort` принимает два указателя на начало и конец диапазона, который нужно отсортировать. В данном случае, мы передаем указатели на первый и последний элементы массива. После сортировки, мы выводим отсортированный массив на экран.
Примечание: В данном примере используется массив символов (`char`), но аналогичный подход можно применить и для массива строк (`std::string`).
Надеюсь, это поможет! Если у вас есть еще вопросы, не стесняйтесь задавать.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili