Вопрос задан 22.02.2019 в 22:52. Предмет Информатика. Спрашивает Denver Lesha.

Требуется написать программу, которая получает с клавиатуры координаты точки на плоскости (x,y –

действительные числа) и определить принадлежность точки заштрихованной области, включая ее границы.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Макарцова Ева.
Var x,y:real;
begin
write('x, y:');
readln(x,y);
if (y<=-0.75*x*x+5)and(y>=x)and(y>=-x)
 then writeln('Точка принадлежит заштрихованной области')
 else writeln('Точка не принадлежит заштрихованной области');
end.

Пример:
x, y:
2 1
Точка не принадлежит заштрихованной области
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос