Вопрос задан 22.02.2019 в 16:47.
Предмет Информатика.
Спрашивает Sattorova Raisa.
PASCAL Напишите программу, которая в последовательности натуральных чисел находит количество
отрицательных чисел, кратных 10. Программа получает на вход натуральные числа, количество введенных числе неизвестно, последовательность чисел заканчивается числом -100 (минус 100). Задачу решить циклом While.Ответы на вопрос
Отвечает Калиева Карлыгаш.
Var
n,k:integer;
loop:boolean;
begin
Writeln('Введите целые числа, окончание ввода по числу -100');
k:=0;
loop:=true;
while loop do
begin
Read(n);
loop:=(n<>-100);
if loop then
if (n<0) and ((n mod 10)=0) then Inc(k)
end;
Writeln('Количество отрицательных чисел, кратных 10, равно ',k)
end.
Тестовое решение:
Введите целые числа, окончание ввода по числу -100
40 52 -23 16 1000 -240 35 6 0 -20 7 -100
Количество отрицательных чисел, кратных 10, равно 2
n,k:integer;
loop:boolean;
begin
Writeln('Введите целые числа, окончание ввода по числу -100');
k:=0;
loop:=true;
while loop do
begin
Read(n);
loop:=(n<>-100);
if loop then
if (n<0) and ((n mod 10)=0) then Inc(k)
end;
Writeln('Количество отрицательных чисел, кратных 10, равно ',k)
end.
Тестовое решение:
Введите целые числа, окончание ввода по числу -100
40 52 -23 16 1000 -240 35 6 0 -20 7 -100
Количество отрицательных чисел, кратных 10, равно 2
Отвечает Кирилова Милена.
var
x, s : integer;
t: boolean;
begin
s := 0;
while t=false do
begin
writeln(i,' число:');
readln(x);
if x = -100 then t:=true;
if (x < 0) and (x mod 10 = 0)) then s:=s+1;
end;
writeln('Ответ ',s)
end.
x, s : integer;
t: boolean;
begin
s := 0;
while t=false do
begin
writeln(i,' число:');
readln(x);
if x = -100 then t:=true;
if (x < 0) and (x mod 10 = 0)) then s:=s+1;
end;
writeln('Ответ ',s)
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Программа на языке Pascal, которая находит количество отрицательных чисел, кратных 10, в последовательности натуральных чисел, может выглядеть следующим образом:
```pascal program CountNegativeMultiplesOfTen;
var number, count: integer;
begin count := 0; // инициализация счетчика
write('Введите число: '); readln(number);
while number <> -100 do begin if (number < 0) and (number mod 10 = 0) then count := count + 1; // увеличиваем счетчик, если число отрицательное и кратно
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 266
Информатика 25
Информатика 33
Информатика 16
Информатика 10
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
