Вопрос задан 22.02.2019 в 10:57. Предмет Информатика. Спрашивает Ехимова Лиза.

Дан массив из 10 целых чисел. Определите, сколько элементов этого массива имеют максимальное

значение. Надо написать на Паскале, объяснить при этом всё, ещё и блок схему надо
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Саньков Виталий.
Var m:array[1..10] of integer; i,max,cnt:integer;
begin
max := -1000;
write('Massive: ');
for i := 1 to 10 do begin
m[i] := random (11)-5;
write(m[i],' ');
if m[i] > max then begin inc(cnt); max := m[i]; end;
end;
writeln;
writeln('Максимальное число: ',max);
writeln('Всего максимальных чисел: ', cnt);
end.
0 0
Отвечает Ляпина Марина.
Var m:array[1..10] of integer; i,max,cnt:integer;
begin
max := -1000;
write('Massive: ');
for i := 1 to 10 do begin
m[i] := random (11)-5;
write(m[i],' ');
if m[i] > max then begin inc(cnt); max := m[i]; end;
end;
writeln;
writeln('Максимальное число: ',max);
writeln('Всего максимальных чисел: ', cnt);
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения данной задачи на Паскале можно использовать следующий алгоритм:

1. Объявляем массив из 10 целых чисел. 2. Заполняем массив целыми числами. 3. Инициализируем переменную "максимальное значение" с первым элементом массива. 4. Инициализируем переменную "количество максимальных элементов" с 1. 5. Проходим циклом по оставшимся элементам массива, начиная со второго элемента. 6. Внутри цикла проверяем, если текущий элемент больше или равен "максимальному значению", то обновляем "максимальное значение" и увеличиваем "количество максимальных элементов" на 1. 7. После завершения цикла выводим значение "количество максимальных элементов".

Пример кода на Паскале:

```pascal program MaxElementCount; var arr: array[1..10] of integer; maxVal, countMax: integer; i: integer; begin writeln('Введите 10 целых чисел:'); for i := 1 to 10 do readln(arr[i]); maxVal := arr[1]; countMax := 1; for i := 2 to 10 do begin if arr[i] >= maxVal then begin if arr[i] > maxVal then begin maxVal := arr[i]; countMax := 1; end else countMax := countMax + 1; end; end; writeln('Количество элементов с максимальным значением: ', countMax); end. ```

Блок-схема для данного алгоритма:

``` ┌───────┐ │ Ввод 10 чисел │ └───────┘ │ ▼ ┌───────────────────┐ │ maxVal := arr[1] │ │ countMax := 1 │ └───────────────────┘ │ ▼ ┌───────────────────────────┐ │ for i := 2 to 10 do │ │ if arr[i] >= maxVal then│ │ if arr[i] > maxVal then│ │ maxVal := arr[i] │ │ countMax := 1 │ │ else │ │ countMax := countMax + 1│ └───────────────────────────┘ │ ▼ ┌───────────────────┐ │ Вывод countMax │ └───────────────────┘ ```

Таким образом, данный код позволяет определить количество элементов массива, имеющих максимальное значение.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос