Написать программу, которая по паролю будет определять уровень доступа сотрудника к секретной
информации в базе данных. Доступ к базе имеют только шесть человек, разбитых на три группы по степени доступа. Они имеют следующие пароли: 9583, 1747 — доступны модули баз А, В, С; 3331, 7922 — доступны модули баз В, С; 9455, 8997 — доступен модуль базы С. Пожалуйста помогите надо до завтраОтветы на вопрос
begin
readln(key);
case key of
9583,1747:writeln('A, B, C');
3331,7922:writeln('B, C');
9455,8997:writeln('C');
end;
end.
Для решения данной задачи можно использовать словарь, где ключами будут пароли, а значениями - уровни доступа. Затем, после ввода пароля пользователем, программа будет проверять его наличие в словаре и выводить соответствующий уровень доступа.
Вот пример программы на языке Python, решающей данную задачу:
```python # Создаем словарь с паролями и уровнями доступа passwords = { 9583: "Доступ к модулям баз А, В, С", 1747: "Доступ к модулям баз А, В, С", 3331: "Доступ к модулям баз В, С", 7922: "Доступ к модулям баз В, С", 9455: "Доступ к модулю базы С", 8997: "Доступ к модулю базы С" }
# Ввод пароля пользователем password = int(input("Введите пароль: "))
# Проверка наличия пароля в словаре if password in passwords: access_level = passwords[password] print("Уровень доступа:", access_level) else: print("Неверный пароль") ```
Программа начинается с создания словаря `passwords`, где ключами являются пароли, а значениями - уровни доступа. Затем, с помощью функции `input()` пользователь вводит пароль, который преобразуется в целое число с помощью функции `int()`. Далее, программа проверяет наличие введенного пароля в словаре `passwords` с помощью условного оператора `if`. Если пароль присутствует в словаре, то программа выводит соответствующий уровень доступа. В противном случае, выводится сообщение о неверном пароле.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
