
Дано целое число N. Составить программу нахождения количества цифр числа (Pascal ABC)


Ответы на вопрос

a:longint;
s:string;
begin
writeln('Введите целое число');
readln(a);
Str(a,s);
writeln('Количество цифр в числе равно ',length(s));
end.



Нахождение количества цифр в числе на Pascal ABC
Для нахождения количества цифр в числе N на языке Pascal ABC можно использовать следующую программу:
```pascal program CountDigits; var N, count: Integer; begin write('Введите число N: '); readln(N); count := 0; while N > 0 do begin N := N div 10; count := count + 1; end; writeln('Количество цифр в числе N: ', count); end. ```
В этой программе мы считываем число N с помощью `readln(N)`, а затем используем цикл `while` для нахождения количества цифр. Внутри цикла мы делим число N на 10 с помощью оператора `div` и увеличиваем счетчик `count` на 1. Цикл продолжается, пока число N больше нуля. После окончания цикла выводим результат с помощью `writeln('Количество цифр в числе N: ', count)`.
Пример работы программы:
``` Введите число N: 12345 Количество цифр в числе N: 5 ```


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili