 
ПаскальЗашифровать слово, поставив букве ее номер в алфавите.
 0
        0
         0
        0
    Ответы на вопрос
 
        i:integer;
begin
readln(s);
for i:=1 to length(s) do
if s[i] in ['А'..'Я'] then write(ord(s[i])-ord('А')+1,' ')
else write(ord(s[i])-ord('а')+1,' ');
end.
 0
                    0
                     0
                    0
                 
            Шифрование слова в Паскале
Для шифрования слова в Паскале, используя номера букв в алфавите, можно написать программу, которая будет принимать слово и затем заменять каждую букву на ее номер в алфавите.
Пример кода на Паскале для шифрования слова "hello": ``` program EncryptWord; var word: string; encryptedWord: string; i: integer; begin word := 'hello'; encryptedWord := ''; for i := 1 to length(word) do begin encryptedWord := encryptedWord + IntToStr(ord(word[i]) - 96) + ' '; end; writeln('Encrypted word: ', encryptedWord); end. ```
В этом примере программа берет каждую букву в слове "hello", находит ее номер в алфавите (вычитая код буквы 'a' и добавляя 1) и добавляет этот номер к зашифрованному слову.
Пример вывода: ``` Encrypted word: 8 5 12 12 15 ```
Таким образом, слово "hello" зашифровано в "8 5 12 12 15".
Этот метод шифрования использует простую замену букв на их номера в алфавите и может быть расшифрован обратным способом, зная номера букв.
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			