1.Дано целое двузначное число. Написать программу которая находит квадрат суммы его цифр. pascal
Ответы на вопрос
var a, b, c, d:integer;
begin
writeln ('Нахождение квадрата суммы цифр двузначного числа');
writeln ('Введите число ');
readln (a);
b:= a mod 10;
a:= a div 10;
c:= a mod 10;
a:= a div 10;
d:= sqr (b + c);
writeln ('Ответ: ', d)
end.
Для решения данной задачи в Pascal можно использовать следующий алгоритм:
1. Считываем двузначное число с помощью функции ReadLn и сохраняем его в переменную number. 2. Разбиваем число на отдельные цифры, выделяя десятки и единицы. Для этого можно использовать операции деления на 10 и остаток от деления на 10. 3. Вычисляем сумму цифр числа, складывая десятки и единицы. 4. Возводим сумму цифр в квадрат с помощью операции возведения в степень. 5. Выводим результат, используя функцию WriteLn.
Пример реализации данного алгоритма на Pascal:
``` program SquareSumOfDigits;
var number, tens, ones, sum: integer; begin // Шаг 1 WriteLn('Введите двузначное число:'); ReadLn(number); // Шаг 2 tens := number div 10; ones := number mod 10; // Шаг 3 sum := tens + ones; // Шаг 4 sum := sum * sum; // Шаг 5 WriteLn('Квадрат суммы цифр числа: ', sum); end. ```
После запуска программы она попросит ввести двузначное число, например, 42. Затем она вычислит сумму цифр (4 + 2 = 6) и возведет ее в квадрат (6 * 6 = 36). На экран будет выведено сообщение "Квадрат суммы цифр числа: 36".
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
