Вопрос задан 20.02.2019 в 05:57.
Предмет Информатика.
Спрашивает Shtets Vasya.
Составьте программу которая заменяет в строке s буквы е на и и буквы а на о
Ответы на вопрос
Отвечает Бакиров Алмаз.
Program n;
var
i: integer;
st: string;
begin
writeln('Введите строку');
readln(st);
for i:=1 to length(st) do begin
if st[i]='е' then st[i]:='и';
if st[i]='а' then st[i]:='о';
end;
writeln(st);
end.
var
i: integer;
st: string;
begin
writeln('Введите строку');
readln(st);
for i:=1 to length(st) do begin
if st[i]='е' then st[i]:='и';
if st[i]='а' then st[i]:='о';
end;
writeln(st);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Замена букв в строке
Вы можете использовать следующую программу на Python для замены букв в строке:
```python s = input("Введите строку: ") s = s.replace('е', 'и') s = s.replace('а', 'о') print("Результат замены:", s) ```
Эта программа запрашивает у пользователя ввод строки, затем заменяет все вхождения буквы 'е' на 'и' и все вхождения буквы 'а' на 'о'. Затем программа выводит результат замены.
Например, если вы введете строку "Привет, мир!", программа заменит буквы 'е' на 'и' и буквы 'а' на 'о', и результат будет выглядеть так: "Привит, мир!".
Примечание: Это пример программы на языке Python, который выполняет замену букв в строке. Если вам нужна программа на другом языке программирования, пожалуйста, уточните это.
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 24
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
