Напишите программу в Boland Pascal.ЗАДАНО ТРЕХЗНАЧное числою напечатать в обратном порядке .
Входные данные Целое трехзначное число. Выходные данные Целое трехзначное число напечатать в обратном порядке Пример входных данных423 . Пример выходных данных 324.Ответы на вопрос
begin
write('число: '); readln(n);
repeat
write(n mod 10);
n:=n div 10;
until n=0;
end.
Ввод - вывод:
число: 589
985
Программа на Boland Pascal для печати трехзначного числа в обратном порядке:
```pascal program ReverseNumber;
var number, reverseNumber: Integer; digit1, digit2, digit3: Integer;
begin // Ввод трехзначного числа Write('Введите трехзначное число: '); Readln(number);
// Получение цифр числа digit1 := number div 100; digit2 := (number div 10) mod 10; digit3 := number mod 10;
// Формирование обратного числа reverseNumber := digit3 * 100 + digit2 * 10 + digit1;
// Вывод обратного числа Writeln('Обратное число: ', reverseNumber);
end. ```
Программа запрашивает у пользователя трехзначное число, затем разделяет его на цифры и формирует обратное число путем сборки цифр в обратном порядке. Наконец, программа выводит обратное число на экран.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
