
Написать задачу про кассу,паскаль информатика 9 класс.Касса должна считатать кол во товаров,их
стоимость и выдавать сдачу.Должна выдавать ошибку если пользователю не хватает денег

Ответы на вопрос

Спасибо за отметку "Лучший ответ" и нажатую кнопочку "Спасибо" (:



Задача на Паскаль для 9 класса по информатике:
Напишите программу для кассового аппарата, которая должна считать количество товаров, их стоимость и выдавать сдачу. Программа должна также выдавать ошибку, если пользователю не хватает денег для оплаты товаров.
Пример реализации программы на языке Паскаль:
program CashRegister; var totalItems, totalCost, paidAmount, change: real; begin writeln('Welcome to the cash register program!'); writeln('Please enter the total number of items: '); readln(totalItems); writeln('Please enter the total cost of the items: '); readln(totalCost); writeln('Please enter the amount paid by the customer: '); readln(paidAmount); if paidAmount < totalCost then writeln('Error: Insufficient funds!') else begin change := paidAmount - totalCost; writeln('Total items: ', totalItems); writeln('Total cost: ', totalCost:0:2); writeln('Amount paid: ', paidAmount:0:2); writeln('Change: ', change:0:2); end; end.
Эта программа позволит пользователю вводить количество товаров, их стоимость и оплачиваемую сумму. В случае, если оплаченная сумма недостаточна для оплаты товаров, программа выдаст ошибку. В противном случае, программа выведет информацию о количестве товаров, их стоимости, оплаченной сумме и сдаче.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili