
Задан двумерный массив Y из 7-и строк и 3-х столбцов. Составить программу подсчёта суммы
произведений элементов строк. Pascal

Ответы на вопрос

// Внимание! Если программа не работает, обновите версию!
begin
Writeln('*** Исходный массив ***');
var a:=MatrRandom(7,3,-99,99);
a.Println(4); Writeln(4*a.ColCount*'-');
Writeln('S= ',a.Rows.Select(r->r.Aggregate(1,(x,y)->x*y)).Sum)
end.
Пример
*** Исходный массив ***
-58 86 46
-76 -50 38
35 -98 -93
-81 21 21
-20 32 -84
-80 32 -8
-8 -6 55
------------
S= 275101



Для подсчета суммы произведений элементов строк в двумерном массиве Y из 7 строк и 3 столбцов можно использовать следующий код на Pascal:
program SumOfProducts; var Y: array[1..7, 1..3] of integer; i, j, sum: integer; begin sum := 0; // Заполнение массива Y случайными значениями for i := 1 to 7 do for j := 1 to 3 do Y[i, j] := Random(10) + 1; // случайные значения от 1 до 10 // Вывод массива Y writeln('Массив Y:'); for i := 1 to 7 do begin for j := 1 to 3 do write(Y[i, j]:3); writeln; end; // Подсчет суммы произведений элементов строк for i := 1 to 7 do begin var product: integer := 1; for j := 1 to 3 do product := product * Y[i, j]; sum := sum + product; end; // Вывод результата writeln('Сумма произведений элементов строк: ', sum); end.
Этот код создает двумерный массив Y, заполняет его случайными значениями, вычисляет сумму произведений элементов каждой строки и выводит результат.


Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili