Вопрос задан 18.02.2019 в 13:49. Предмет Информатика. Спрашивает Корчагин Ярославик.

Составьте программу оператора выбора.Просто по примеру,но со своими вариантами.Заранее спасибо.))

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Пернебек Бекасыл.
Begin
var a:integer;
WriteLN('Введите номер дня недели: ');
ReadLN(a);
if a = 1 then begin
WriteLN('Понедельник-Количество уроков: 6')
end;
if a = 2 then begin
WriteLN('Вторник-Количество уроков: 6')
end;
if a = 3 then begin
WriteLN('Среда-Количество уроков: 6')
end;
a = 4 then begin
WriteLN('Четверг-Количество уроков: 6')
end;
if a = 5 then begin
WriteLN('Пятница-Количество уроков: 6')
end;
if a = 6 then begin
WriteLN('Суббота-Количество уроков: 6')
end;
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа оператора выбора

Программа оператора выбора, также известная как оператор switch, позволяет выбирать различные варианты выполнения кода в зависимости от значения переменной. Вот пример программы оператора выбора на языке Python:

```python # Пример программы оператора выбора

# Запросить у пользователя ввод числа number = int(input("Введите число: "))

# Использовать оператор выбора для выполнения различных действий в зависимости от значения числа switch(number): case 1: print("Вы ввели число 1") break case 2: print("Вы ввели число 2") break case 3: print("Вы ввели число 3") break default: print("Вы ввели число, отличное от 1, 2 и 3")

# Программа завершена print("Программа завершена") ```

В этом примере программа запрашивает у пользователя ввод числа, а затем использует оператор выбора для выполнения различных действий в зависимости от значения числа. Если пользователь вводит число 1, программа выводит сообщение "Вы ввели число 1". Если пользователь вводит число 2, программа выводит сообщение "Вы ввели число 2". Если пользователь вводит число 3, программа выводит сообщение "Вы ввели число 3". Если пользователь вводит число, отличное от 1, 2 и 3, программа выводит сообщение "Вы ввели число, отличное от 1, 2 и 3". В конце программы выводится сообщение "Программа завершена".

Примечание: Приведенный выше пример программы оператора выбора написан на языке Python, но оператор выбора также доступен на других языках программирования, таких как C++, Java и других. Синтаксис и использование оператора выбора могут немного отличаться в разных языках программирования.

Примеры вариантов программы оператора выбора

Вот несколько примеров вариантов программы оператора выбора:

1. Программа, которая выводит день недели в зависимости от введенного числа:

```python # Программа оператора выбора для вывода дня недели

# Запросить у пользователя ввод числа от 1 до 7 day_number = int(input("Введите число от 1 до 7: "))

# Использовать оператор выбора для вывода дня недели в зависимости от числа switch(day_number): case 1: print("Понедельник") break case 2: print("Вторник") break case 3: print("Среда") break case 4: print("Четверг") break case 5: print("Пятница") break case 6: print("Суббота") break case 7: print("Воскресенье") break default: print("Вы ввели число, отличное от 1 до 7")

# Программа завершена print("Программа завершена") ```

2. Программа, которая определяет тип геометрической фигуры в зависимости от введенного числа:

```python # Программа оператора выбора для определения типа геометрической фигуры

# Запросить у пользователя ввод числа от 1 до 3 shape_number = int(input("Введите число от 1 до 3: "))

# Использовать оператор выбора для определения типа геометрической фигуры в зависимости от числа switch(shape_number): case 1: print("Треугольник") break case 2: print("Квадрат") break case 3: print("Круг") break default: print("Вы ввели число, отличное от 1 до 3")

# Программа завершена print("Программа завершена") ```

3. Программа, которая выполняет различные математические операции в зависимости от введенного числа:

```python # Программа оператора выбора для выполнения математических операций

# Запросить у пользователя ввод числа от 1 до 4 operation_number = int(input("Введите число от 1 до 4: "))

# Использовать оператор выбора для выполнения математической операции в зависимости от числа switch(operation_number): case 1: # Сложение num1 = int(input("Введите первое число: ")) num2 = int(input("Введите второе число: ")) result = num1 + num2 print("Результат сложения:", result) break case 2: # Вычитание num1 = int(input("Введите первое число: ")) num2 = int(input("Введите второе число: ")) result = num1 - num2 print("Результат вычитания:", result) break case 3: # Умножение num1 = int(input("Введите первое число: ")) num2 = int(input("Введите второе число: ")) result = num1 * num2 print("Результат умножения:", result) break case 4: # Деление num1 = int(input("Введите первое число: ")) num2 = int(input("Введите второе число: ")) result = num1 / num2 print("Результат деления:", result) break default: print("Вы ввели число, отличное от 1 до 4")

# Программа завершена print("Программа завершена") ```

В этих примерах программы оператора выбора демонстрируют различные варианты использования оператора выбора для выполнения различных действий в зависимости от значения переменной. Вы можете изменять код в соответствии с вашими потребностями и добавлять свои собственные варианты выполнения кода в программе оператора выбора.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос