Вопрос задан 18.02.2019 в 10:29.
Предмет Информатика.
Спрашивает Сейсембаевы Мурат-Айтолкын.
Составить программу на языке паскаль: из 100 чисел выбирают 20 праизвольным образом если среди
выбраных чисел есть число 50 то указать его номер если нет то указать что числа 50 нетОтветы на вопрос
Отвечает Попов Никита.
Program n_1;
const N = 20;
ver
a:array [1.N] of integer;
i:integer;
begin
randomize;
for i:=1 to N do begin
a[i]:= random(101);
write (a[i]:3);
end;
writeln;
for I:=1 to N do
if a[i]=50 then
writeln('Да',i)
else writeln ('Нет');
readln;
end.
const N = 20;
ver
a:array [1.N] of integer;
i:integer;
begin
randomize;
for i:=1 to N do begin
a[i]:= random(101);
write (a[i]:3);
end;
writeln;
for I:=1 to N do
if a[i]=50 then
writeln('Да',i)
else writeln ('Нет');
readln;
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Программа на языке Паскаль:
program FindNumber;
var numbers: array[1..100] of integer; chosenNumbers: array[1..20] of integer; i, j, number50: integer;
begin // Заполнение массива числами от 1 до 100 for i := 1 to 100 do begin numbers[i] := i; end;
// Выбор 20 чисел из массива numbers for i := 1 to 20 do begin j := random(100) + 1; chosenNumbers[i] := numbers[j]; end;
// Поиск числа 50 среди выбранных чисел number50 := 0; for i := 1 to 20 do begin if chosenNumbers[i] = 50 then begin number50 := i; break; end; end;
// Вывод результата if number50 > 0 then writeln('Число 50 найдено под номером ', number50) else writeln('Числа 50 нет среди выбранных чисел'); end.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
