
Помогите пожалуйста язык паскаль) Ввести двумерный массив A 4×3. Определить в нём произведение тех
элементов, чей модуль лежит вне диапазона [1;5].

Ответы на вопрос

m = 4;
n = 3;
var
a: array[1..m, 1..n] of integer;
i, j, t: integer;
p: longint;
begin
Randomize;
Writeln('Исходный массив');
p := 1;
for i := 1 to m do
begin
for j := 1 to n do
begin
a[i, j] := Random(19) - 9;
Write(a[i, j]:3);
if (abs(a[i, j]) < 1) or (abs(a[i, j]) > 5) then p := p * a[i, j]
end;
Writeln
end;
Writeln('Произведение элементов с модулем вне [1;5] равно ', p)
end.
Тестовое решение:
Исходный массив
-8 2 7
-3 -8 5
1 -4 -3
6 9 6
Произведение элементов с модулем вне [1;5] равно 145152



Описание задачи
Вы хотите написать программу на языке Паскаль, которая будет вводить двумерный массив размером 4x3 и находить произведение элементов, модуль которых не находится в диапазоне [1;5].
Решение
Вот пример программы на языке Паскаль, которая решает эту задачу:
```pascal program TwoDimensionalArray;
const ROWS = 4; COLS = 3;
var A: array[1..ROWS, 1..COLS] of Integer; i, j: Integer; product: Integer; isInRange: Boolean;
begin // Ввод двумерного массива writeln('Введите элементы двумерного массива:'); for i := 1 to ROWS do begin for j := 1 to COLS do begin write('A[', i, ',', j, ']: '); readln(A[i, j]); end; end;
// Находим произведение элементов, модуль которых не входит в диапазон [1;5] product := 1; for i := 1 to ROWS do begin for j := 1 to COLS do begin if (Abs(A[i, j]) < 1) or (Abs(A[i, j]) > 5) then begin product := product * A[i, j]; isInRange := False; end; end; end;
// Вывод результата if isInRange then writeln('Все элементы находятся в диапазоне [1;5].') else writeln('Произведение элементов, модуль которых не входит в диапазон [1;5]: ', product);
readln; end. ```
Программа сначала запрашивает у пользователя ввод элементов двумерного массива размером 4x3. Затем она проверяет каждый элемент и находит произведение элементов, модуль которых не входит в диапазон [1;5]. Если все элементы находятся в диапазоне [1;5], программа выводит сообщение "Все элементы находятся в диапазоне [1;5]". В противном случае, она выводит произведение таких элементов.
Надеюсь, это решение помогло вам! Если у вас есть дополнительные вопросы, пожалуйста, дайте мне знать.


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili