Написать программу "Калькулятор", которая выводит результат выполнения одной из операций( + ; - ; *
; / ) над двумя числами a и b. (Pascal)Ответы на вопрос
C:integer;
Begin
WriteLn(1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление, 0 - выход);
ReadLn(C);
While C <> 0 do
Begin
Write(Введите два числа: );
ReadLn(A,B);
Write(Ответ: );
Case C of
1:WriteLn(A+B);
2:WriteLn(A-B);
3:WriteLn(A*B);
4:WriteLn(A/B);
End;
WriteLn(1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление, 0 - выход);
ReadLn(C);
End;
Program "Calculator" in Pascal
To create a simple calculator program in Pascal that performs one of the basic arithmetic operations (+, -, *, /) on two numbers, you can use the following code:
```pascal program Calculator;
var a, b, result: real; operation: char;
begin writeln('Enter the first number: '); readln(a); writeln('Enter the second number: '); readln(b); writeln('Enter the operation (+, -, *, /): '); readln(operation);
case operation of '+': result := a + b; '-': result := a - b; '*': result := a * b; '/': result := a / b; else writeln('Invalid operation'); end;
writeln('Result: ', result:0:2); end. ```
This program prompts the user to enter two numbers and the desired operation, then performs the calculation and displays the result.
Note: This is a basic example to demonstrate the concept. In a real-world scenario, you would want to include error handling for division by zero and other potential issues.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
