
Составить программу в паскаль, где при вводе любого трехзначного числа в результате все цифры этого
числа записаны через запятую.Пожалуйста Например Введите трехзначное число 123 Результат 1,2,3

Ответы на вопрос

var a: integer;
begin
write('Введите трехзначное число: ');
readln(a);
write('результат: ',a div 100,',',a mod 100 div 10,',',a mod 10);
end.



var
s:string;
begin
Write('Введите трехзначное число -> ');
readln(s);
Write('Результат -> ',s[1], ',');
write(s[2], ',');
Write(s[3]);
end.
Пример:
Введите трехзначное число -> 453
Результат -> 4,5,3



Вот пример программы на языке Pascal, которая принимает трехзначное число от пользователя и выводит все его цифры через запятую:
```pascal program ThreeDigitNumber; var number, digit1, digit2, digit3: integer; begin writeln('Введите трехзначное число:'); readln(number); digit1 := number div 100; // первая цифра digit2 := (number div 10) mod 10; // вторая цифра digit3 := number mod 10; // третья цифра writeln('Результат: ', digit1, ',', digit2, ',', digit3); end. ```
При запуске программы, она запросит у пользователя ввести трехзначное число. Затем она разделит это число на отдельные цифры, используя операции деления и остатка от деления. Наконец, она выведет результат, разделяя цифры запятыми.
Например, если вы введете число 123, программа выведет: "Результат: 1,2,3".
Примечание: Программа написана на языке Pascal, и для ее выполнения вам понадобится среда разработки, поддерживающая этот язык, например, Free Pascal или Turbo Pascal.


Топ вопросов за вчера в категории Информатика








Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili