Помогите решить задачу по информатике в паскале!написать программу, которая по известному тангенсу
угла вычисляет угол в градусахОтветы на вопрос
r: real;
begin
readln(r);
writeln(System.Math.Atan(r) * 180 / Pi);
end.
Я могу помочь вам с вашей задачей по информатике. Для того, чтобы написать программу на Паскале, которая по известному тангенсу угла вычисляет угол в градусах, вам нужно использовать функцию arctan, которая возвращает арктангенс аргумента в радианах. Затем вам нужно перевести радианы в градусы, умножив их на 180 и разделив на число пи. Вот пример такой программы:
```pascal program AngleByTangent; var tan, angle: real; begin writeln('Введите тангенс угла:'); readln(tan); angle := arctan(tan) * 180 / pi; // переводим радианы в градусы writeln('Угол в градусах равен: ', angle:0:2); // выводим угол с двумя знаками после запятой end. ```
Вы можете найти больше информации о функции arctan и тригонометрических функциях на Паскале на этих сайтах: [Функция тангенса — онлайн калькулятор, формулы, график](https://www.calculat.org/ru/%d1%82%d1%80%d0%b8%d0%b3%d0%be%d0%bd%d0%be%d0%bc%d0%b5%d1%82%d1%80%d0%b8%d1%87%d0%b5%d1%81%d0%ba%d0%b8%d0%b5-%d1%84%d1%83%d0%bd%d0%ba%d1%86%d0%b8%d0%b8/%d1%82%d0%b0%d0%bd%d0%b3%d0%b5%d0%bd%d1%81/), [Тангенс угла — tg(A) | Формулы и расчеты онлайн - Fxyz.ru](https://www.fxyz.ru/%D1%84%D0%BE%D1%80%D0%BC%D1%83%D0%BB%D1%8B_%D0%BF%D0%BE_%D0%B3%D0%B5%D0%BE%D0%BC%D0%B5%D1%82%D1%80%D0%B8%D0%B8/%D1%83%D0%B3%D0%BB%D1%8B_%D1%83%D0%B3%D0%BE%D0%BB/%D1%82%D1%80%D0%B8%D0%B3%D0%BE%D0%BD%D0%BE%D0%BC%D0%B5%D1%82%D1%80%D0%B8%D1%87%D0%B5%D1%81%D0%BA%D0%B8%D0%B5_%D1%84%D1%83%D0%BD%D0%BA%D1%86%D0%B8%D0%B8_%D0%BE%D1%81%D1%82%D1%80%D0%BE%D0%B3%D0%BE_%D1%83%D0%B3%D0%BB%D0%B0/%D1%82%D0%B0%D0%BD%D0%B3%D0%B5%D0%BD%D1%81_%D1%83%D0%B3%D0%BB%D0%B0_tg/), [Как найти угол по тангенсу](https://bing.com/search?q=%d0%ba%d0%b0%d0%ba+%d0%b2%d1%8b%d1%87%d0%b8%d1%81%d0%bb%d0%b8%d1%82%d1%8c+%d1%83%d0%b3%d0%be%d0%bb+%d0%bf%d0%be+%d1%82%d0%b0%d0%bd%d0%b3%d0%b5%d0%bd%d1%81%d1%83+%d0%b2+%d0%bf%d0%b0%d1%81%d0%ba%d0%b0%d0%bb%d0%b5). Надеюсь, это вам поможет. Удачи!
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
