Дан массив из 10 элементов. составить программу, находящую среднее арифметическое положительных.
Ответы на вопрос
uses crt;
var massiv:array[1..10] of integer;
i,count:integer;
sra:real;
begin
for i:=0 to 10 do begin
readln(massiv[i]);
if massiv[i] > 0 then begin
count:= count+1;
sra:= sra + massiv[i];
end;
end;
sra:= sra/count;
writeln('Среднее арифметическое = ',sra);
end.
Для нахождения среднего арифметического положительных элементов в массиве из 10 элементов, можно использовать следующую программу на языке Pascal:
```pascal program average; const n = 10; var mas: array[1..10] of integer; i, count, sum: integer; average: real; begin count := 0; sum := 0; for i := 1 to n do begin mas[i] := random(100); writeln(mas[i]); if mas[i] > 0 then begin count := count + 1; sum := sum + mas[i]; end; end; if count > 0 then average := sum / count else average := 0; writeln('Среднее арифметическое положительных элементов: ', average:5:1); end. ```
В этой программе мы объявляем массив `mas` из 10 элементов и переменные `i`, `count`, `sum` и `average`. Затем мы используем цикл `for` для заполнения массива случайными числами от 0 до 100 и выводим их на экран. Внутри цикла мы проверяем, является ли текущий элемент положительным. Если да, то увеличиваем счетчик `count` и добавляем значение элемента к сумме `sum`.
После завершения цикла, мы проверяем значение счетчика `count`. Если он больше нуля, то вычисляем среднее арифметическое как отношение суммы `sum` к количеству положительных элементов `count`. В противном случае, если положительных элементов нет, среднее арифметическое будет равно 0.
Наконец, мы выводим среднее арифметическое положительных элементов на экран.
Примечание: Приведенная программа использует генератор случайных чисел для заполнения массива. Если вам нужно ввести значения вручную, вы можете изменить эту часть программы соответствующим образом.
Надеюсь, это поможет! Если у вас есть еще вопросы, не стесняйтесь задавать.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
